Mercedes EQ All Electric Forum banner

MBUX Navigation Icons

4231 Views 9 Replies 3 Participants Last post by  Sezer mazi
7
I regularly keep getting icons on the navigation display that do not have a clue what they indicate. They appear randomly and disappear quickly. I have managed to catch some screenshots. Does anyone have any idea what they indicate
Vehicle Speedometer Motor vehicle Car Automotive navigation system

Vehicle Car Motor vehicle Light Automotive tire

Land vehicle Vehicle Speedometer Motor vehicle Car

Vehicle Speedometer Car Light Motor vehicle

Vehicle Plant Communication Device Gadget Audio equipment

Vehicle Motor vehicle Automotive design Speedometer Gps navigation device

Vehicle Automotive navigation system Gps navigation device Speedometer Sky
See less See more
1 - 10 of 10 Posts
I'm not sure which icons you are referring to. The green snakes?
I'm not sure which icons you are referring to. The green snakes?
Yes
They represent how far you can travel though they might be a software bug in those photos unless you were very low in battery at the time. You can try turning them off in navigation settings under show range on map. I will check for exact menu later
That is good to hear, the "green snakes" just keep appearing and disappearing within minutes of appearing but if that is what they are and they can be turned off that would be useful
On my car I can go to touchscreen - navigation - settings icon (wheel with spikes) - range. Or there is another way that may or may not be better which is navigation - settings icon (wheel with spikes) - advanced - view - map elements - range. If range is already disabled, then try enabling it or if enabled then try disabling it.

If that doesn't work, it is even more likely a software bug. You could report it in Mercedes Me app. Also you could experiment with different settings in navigation, for example changing map view to 3d or changing zoom etc may or may not help. I have not seen the problem myself so it could also be that some hardware is an issue also like the gps signal getting confused or something. If you create a new user profile then you can observe if the problem still happens in which case it is more likely a hardware🤣 issue. Be interesting to hear if resolved
Emojied by accident. I clicked delete and a crying face appeared and submitted post. Or something. Anyway I hope you get the general idea.
On my car I can go to touchscreen - navigation - settings icon (wheel with spikes) - range. Or there is another way that may or may not be better which is navigation - settings icon (wheel with spikes) - advanced - view - map elements - range. If range is already disabled, then try enabling it or if enabled then try disabling it.

If that doesn't work, it is even more likely a software bug. You could report it in Mercedes Me app. Also you could experiment with different settings in navigation, for example changing map view to 3d or changing zoom etc may or may not help. I have not seen the problem myself so it could also be that some hardware is an issue also like the gps signal getting confused or something. If you create a new user profile then you can observe if the problem still happens in which case it is more likely a hardware🤣 issue. Be interesting to hear if resolved
Thanks for the advice. Will try and resolve by the pointers you have given and let you know how it works out
  • Like
Reactions: 1
I regularly keep getting icons on the navigation display that do not have a clue what they indicate. They appear randomly and disappear quickly. I have managed to catch some screenshots. Does anyone have any idea what they indicate View attachment 1201
View attachment 1202
View attachment 1203
View attachment 1200
View attachment 1197
View attachment 1199
View attachment 1198
the Green lines are how far you can travel in electric mode if Your vehicle is electric i have it in my mercedes gle 350de but if you want you can disable it
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top