Mercedes EQ All Electric Forum banner
41 - 54 of 54 Posts

·
Registered
Joined
·
13 Posts
Hi all, so I got the car today and have mixed feelings. It may be too early to judge. The bermester sound is missing despite being advised it wouldn't be, the other bits as advised were missing but no john lewis voucher given. Spoke to the leasing Co and they said the missing bits would be retro fitted (despite being told earlier they wouldnt) but I doubt they would replace the speakers. The car has parking sensors but havnt managed to work out if parks
Think I need to play with it more, perhaps I just expected more from a MB AMG or just need to figure things out

The fragrance doesn't work, might be as no energising comfort? Not sure half the time if the lane assist is on or not. Ambient lighting seems limited mostly for the driver to see...maybe missing something or just high expectations. However its only day one so I'll report back. Oh yeah cant open the damn boot either by kicking!
 

·
Registered
Joined
·
26 Posts
Oh dear, that's so annoying. Mine is due to be delivered next Thurs and i have not been advised of this so will be quite pissed as I've made plans to sell my current car so will be stuck. Also aside from the £250 voucher I too have not been offered any reduction.
How is the car, are you happy so far?
Hi Np1.

After a week, I am happy with it despite the missing items. I’m yet to get to grips with the recuperation on the one pedal driving which I don’t use too much of at the moment. I have an issue with speed bumps, of which there are plenty in my area. Even though they are not high, my car hits the road when it goes over the pump. Same goes for where there’s a dip in the road. This means I really have to slow down when I see one of those coming up on the road.
 

·
Registered
Joined
·
28 Posts
Our car arrived on Thursday but MB did not install the Burmester sound system which we were not told about. We got the standard MB sound system. Raised this with them and got the usual ‘due to the shortage of chips etc.’. We still took delivery as other than that, the car is good. Just disappointed that nothing was communicated to us especially as they had already told us about the other 3 missing items. Speaking to the leasing company as to compensation for that. Have driven it a couple of times but still getting used to it.
 

·
Registered
Joined
·
28 Posts
Interesting article in the FT Daimler profits increase despite chip crises….priority of profitable models…nothing about shafting customers with 000’s tech removed from delivered cars….the sham continues….
 

·
Registered
Joined
·
224 Posts
Interesting article in the FT Daimler profits increase despite chip crises….priority of profitable models…nothing about shafting customers with 000’s tech removed from delivered cars….the sham continues….
Ok we get you do not like mercedes. Frankly from all I read and hear on other forums they are neither worse nor better than any of the manufacturers. For every car out there there will be those with good stories and those with bad. Maybe as you no longer have any interest in the EQC you may like to join a forum for BMW?
 

·
Registered
Joined
·
28 Posts
Ok we get you do not like mercedes. Frankly from all I read and hear on other forums they are neither worse nor better than any of the manufacturers. For every car out there there will be those with good stories and those with bad. Maybe as you no longer have any interest in the EQC you may like to join a forum for BMW?
Lol…free speech and all that….always good to have a balance in any forum…I’m not a lone voice here either to be fair surely you have to agree making millions and treating customers as they are at the moment is hardly what one would expect from a premium manufacturer such a Mercedes Benz…there sales practices should be investigated by the completions and markets authority as I say again keeping prices when 000’s in options missing seems very one sided IMO…..
 

·
Registered
Joined
·
224 Posts
Hi Np1.

After a week, I am happy with it despite the missing items. I’m yet to get to grips with the recuperation on the one pedal driving which I don’t use too much of at the moment. I have an issue with speed bumps, of which there are plenty in my area. Even though they are not high, my car hits the road when it goes over the pump. Same goes for where there’s a dip in the road. This means I really have to slow down when I see one of those coming up on the road.
The plastic guards on the wheel arches seem deeper and therefore lower in relation to the car than say my e class and because the ride height of the car is more car like than a real SUV off roader type of vehicle they catch the speed humps frequently and I am sure it is them and not the actual base of the car. We also take extreme caution when going over speed humps of which we now have a proliferation but they are usually in 30km areas so one is going slow anyway. Ihave seen lots of complaints in Indian reviews of this issue. Had no problems with dips in the road but not quite sure what type of dips you mean, perhps those caused by the utility trenches which thankfully are not so much of an issue here,no idea why, use of overhead electric cabling possibly🤷‍♀️
After spending a week or so fiddling with all the methods of driving I have settled on d auto as the best mix with its semi autonomous element the car slows itself on approach to junctions and glides a lot if the road conditions allow. I can travel almost 4km gliding down from my village which makes up for the climb up to it. I use the EQC display flux d’energie screen in French ( I leave the car in French despite the potential to use english) it is the third heading along after consumption. That shows what propulsion is being used ie fwd 4wd or gliding and whether it is discharging or charging. You also get some hints like lift of the accelerator in the head up display to help you maximise economy. It makes for relaxed driving without compromisng performance as it will still accelerate nicely if you need it as in overtaking. Overall I am quite satisfied with the consumption too which is in the WLTP range but I have good driving conditions with not a lot of traffic. I have noticed how much impact encountering other cars and needing to stop or slow down because they are turning or to pass on a narrow road can have on consumption no doubt because of hauling such a heavy car back up to speed. My only gripe I wish mercedes had made d auto the default on start up as sometimes I forget.
 

·
Registered
Joined
·
224 Posts
Hi all, so I got the car today and have mixed feelings. It may be too early to judge. The bermester sound is missing despite being advised it wouldn't be, the other bits as advised were missing but no john lewis voucher given. Spoke to the leasing Co and they said the missing bits would be retro fitted (despite being told earlier they wouldnt) but I doubt they would replace the speakers. The car has parking sensors but havnt managed to work out if parks
Think I need to play with it more, perhaps I just expected more from a MB AMG or just need to figure things out

The fragrance doesn't work, might be as no energising comfort? Not sure half the time if the lane assist is on or not. Ambient lighting seems limited mostly for the driver to see...maybe missing something or just high expectations. However its only day one so I'll report back. Oh yeah cant open the damn boot either by kicking!
Been meaning to respond to this for ages and you have probably worked it out yourself but the lane assist is speed related. So I too noticed the warning indicator was sometimes green and sometimes grey and the penny finally dropped it was speed related. It kicks in at 60km according to the manual😉
 

·
Registered
Joined
·
26 Posts
Hi all, so I got the car today and have mixed feelings. It may be too early to judge. The bermester sound is missing despite being advised it wouldn't be, the other bits as advised were missing but no john lewis voucher given. Spoke to the leasing Co and they said the missing bits would be retro fitted (despite being told earlier they wouldnt) but I doubt they would replace the speakers. The car has parking sensors but havnt managed to work out if parks
Think I need to play with it more, perhaps I just expected more from a MB AMG or just need to figure things out

The fragrance doesn't work, might be as no energising comfort? Not sure half the time if the lane assist is on or not. Ambient lighting seems limited mostly for the driver to see...maybe missing something or just high expectations. However its only day one so I'll report back. Oh yeah cant open the damn boot either by kicking!
Hi Np1. Have you figured out the fragrance yet? Just in case you haven’t gotten it to work, it’s related to the climate control setting on the car. You can set the intensity of the scent release. What if the boot kick-to-open? Mine has worked since day 1 with just kicking underneath softly. The car still doesn’t park but after reading other posts in this forum, I sort of expected that to be the case although I had hoped that MB would have resolved the issue before delivery.
 

·
Registered
Joined
·
224 Posts
Hi Np1. Have you figured out the fragrance yet? Just in case you haven’t gotten it to work, it’s related to the climate control setting on the car. You can set the intensity of the scent release. What if the boot kick-to-open? Mine has worked since day 1 with just kicking underneath softly. The car still doesn’t park but after reading other posts in this forum, I sort of expected that to be the case although I had hoped that MB would have resolved the issue before delivery.
Does the park not work at all? Have to say have never checked it but I believe mine will go backwards or forwards into a parking bay it is just on street ie parrallel parking it will not do.
Agree the kick works all the time if you are close enough ie the key is within 1m ( and if you are there with your key but it was your partners key the car had been driven on and not locked with it will not work until that key is close) also it is a front back movelment not a side to side movement.
 

·
Registered
Joined
·
13 Posts
Sorry I thought I replied to this. The kickboot doesn't work much of the time but I can live without that. I've managed to get the park assist working but it's a bit hit and miss, and also quite scary at times I have had to stop it from potentially hitting another car.

The fragrance is minimal, very occasionally I get a slight smell but that's about it. I've tried all sorts of settings.

With all that said, I am enjoying the drive and having quite some fun putting the pedal to the metal! I do worry if I were to go kn a long journey, I'd really have to drive sensibly and by that I mean 50 to 60 mph with no heating as the range doesn't seem great. I am learning neat new things all the time.

The d-auto is pretty cool although I half expected the car to steer itself ! I've found a profile where I have two tone ambient lights, hit pink and blue, looks very cool and even the kids agreed!

I'll be sure to change to a better range car to allow for my driving habits, no fun otherwise, the eqs seems to have very good range but it may be too expensive however Lucid Air not only looks damn good but claims 500 mile and seems similar to EQC pricing.

Finally I made a formal complaint to the lease Co. As no burmester speakers and the sun roof doesn't slide back only tilts slightly up. Both items should be included on the plus package and neither advised prior to delivery. Plus MB are now saying no retro fit of the other missing items so I'm paying all the extras for nothing!
 

·
Registered
Joined
·
26 Posts
Hi all. In reply to Parkwood’s question on my Park Assist, it just doesn’t work. I try it almost every time just to see if it will eventually work but with no success. It does scan for spaces but doesn’t pick them up.

@Np1 my partner has an issue using the boot kick function but it works for me all them time. Handy when I’m holding things in my hands. I prefer to select the D— function as D-auto has not really been working for me, even when I’m using the SatNav. But I do like it as it helps me slow down a lot before using the brakes, if needed. I don’t use the fragrance as in either alone or with the dogs and don’t want the smell to overpower them. No range anxiety as it’s mostly used locally but sometimes on a long commute. There’s always enough power to return home. Only thing I’ve found is that on the closest rapid charger to me which is a 50kW charger, the car only draws 31kW when charging and it hasn’t been too cold here. Not sure why as the car is set to have maximum charging power and I usually charge it from 15% battery.

We have made a complaint to the leasing company about the price being paid with several thousands of pounds in missing specifications. Needless to say, they have been unhelpful so far in their responses to our queries and we’re about to take it further. MB of course have not been of any help either.

Other than all that, I am still happy with the car. It drives smoothly and is quiet. I’ll be taking it on a long drive to Nottinghamshire soon and will see how the trip goes with the range. I always have the music on but will probably only have the heated seats on as opposed to the climate control which is always on.
 

·
Registered
Joined
·
13 Posts
Hi all. In reply to Parkwood’s question on my Park Assist, it just doesn’t work. I try it almost every time just to see if it will eventually work but with no success. It does scan for spaces but doesn’t pick them up.

@Np1 my partner has an issue using the boot kick function but it works for me all them time. Handy when I’m holding things in my hands. I prefer to select the D— function as D-auto has not really been working for me, even when I’m using the SatNav. But I do like it as it helps me slow down a lot before using the brakes, if needed. I don’t use the fragrance as in either alone or with the dogs and don’t want the smell to overpower them. No range anxiety as it’s mostly used locally but sometimes on a long commute. There’s always enough power to return home. Only thing I’ve found is that on the closest rapid charger to me which is a 50kW charger, the car only draws 31kW when charging and it hasn’t been too cold here. Not sure why as the car is set to have maximum charging power and I usually charge it from 15% battery.

We have made a complaint to the leasing company about the price being paid with several thousands of pounds in missing specifications. Needless to say, they have been unhelpful so far in their responses to our queries and we’re about to take it further. MB of course have not been of any help either.

Other than all that, I am still happy with the car. It drives smoothly and is quiet. I’ll be taking it on a long drive to Nottinghamshire soon and will see how the trip goes with the range. I always have the music on but will probably only have the heated seats on as opposed to the climate control which is always on.
The park assist is hit and miss, doesn't always work for me. It is only supposed to find a spot between two cars however I have purposely passed one many times and it was still searching.
 
41 - 54 of 54 Posts
Top