Mercedes EQ All Electric Forum banner
1 - 15 of 15 Posts

· Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hello,

I just got my 2022 EQC 400 AMG line brand new from the showroom and on my first ride i can hear a slight noise coming from the over head control panel. for your info i am in a third world country where the EV technology has not been introduced much so dealerships dont know much about issues which are un common.

please if anyone has gone through this in any of th EQ series i would be glad if you can help me sort out so that i can tell them to check that specific thing.

secondly as its brand new so i have just charged it once. while charging i could hear some water flowing inside the bonnet area. there is nothing on the floor or any leak. is that normal.

looking forward for your response
 

· Registered
Joined
·
393 Posts
Let us know how you get on or upload video. This seems the best-rated official service center in Pakistan or you could raise issue with Mercedes Me button near mirror. Essentially raise the issue to higher and higher managers until you get resolved. If you don't have confidence in the importer then you could double check the issue in another country like India maybe if willing to put in extra effort but I would be surprised if that is needed.

Note that some slight noises are part of the car and normal, as dBC points out.

Lahore Workshop, GC39+G4J, Block A Divine Gardens, Lahore, Punjab


Source of information:
 

· Registered
Joined
·
10 Posts
Discussion Starter · #11 ·
Let us know how you get on or upload video. This seems the best-rated official service center in Pakistan or you could raise issue with Mercedes Me button near mirror. Essentially raise the issue to higher and higher managers until you get resolved. If you don't have confidence in the importer then you could double check the issue in another country like India maybe if willing to put in extra effort but I would be surprised if that is needed.

Note that some slight noises are part of the car and normal, as dBC points out.

Lahore Workshop, GC39+G4J, Block A Divine Gardens, Lahore, Punjab


Source of information:
Thankyou Dar Jee for your kind reply. i will try and upload a video on youtube tonight and will share it with you. i am pretty sure the sound is not normal.
Lastly unfortunately Shahnawaz limited is our importer and our dealer but unfortunately there are only 2-3 vehicles in pakistan and we are way behind other countries knowledge wise. EV industry is far more ahead and we are lacking behind. i will surely post a video tonigth on youtube and will share the link.

thankyou so much for helpin Dar Jee. Much appreciated

Regards

Agha Gul
 

· Registered
Joined
·
393 Posts
I haven't noticed anything like that in ~3 years of ownership, but I will try to listen carefully over next few days and report only if I notice. It doesn't sound normal but I live in a cooler climate so maybe check if same happens at under 20c (if possible/relevant) as it sort of sounds like a heat pump noise while trying to cool car (in my imagination, not in my experience). You could also ask for a demo EQC car to see if happens in that car too.

I am not a Mercedes engineer or technician so can only hazard a few other layman guesses. I have heard something similar but different - from debris in the air circulation vents which I think was leaves moving from the air in the vent. But this is not from vents I guess. That seemed to cure itself from turning climate control speed to 7 max speed for a minute.

It also sounds also like a wiring connection is not fully connected, such as a light switch almost but not fully switched. Could a button be partially depressed I wonder else could soldering be not fully connected or wiring not fully screwed. I attach diagram of the equipment in that area that is exposed and it is mostly switches especially lighting or telecommunications. Therefore as an initial step I would press each button and listen for any change in noise. Maybe don't press inside SOS flap but just press button once then visually inspect second button inside, if I remember correctly. In this possibility it doesn't seem to be an EV issue but something that could also happen to a GLC.

The telecommunications/media system might also be the source, such as try switching to a different radio channel or turn off bluetooth or make a phone call.

Let us know how you get on with these steps then with dealer or another person may recognise this noise

Product Automotive design Font Automotive parking light Computer
 

· Registered
Joined
·
10 Posts
Discussion Starter · #14 ·
Thankyou for the help. i will surely check the buttons one by one and see if there is any change.
Weather here is cold but since a day or 2 it has become hot. let me check it again by doing these steps and ill post back.

Thanks once again
 

· Registered
Joined
·
10 Posts
Discussion Starter · #15 ·
News update:

Without doing anything that sound coming from the upper panel has gone. i have driven around 500 km, didnt touch a button or change any setting but it has automatically gone.
I dont know whatever was causing the sound has gone bad or i dont know but there is no sound now.

Thankyou everyone
will share my experience once i drive more.
 
1 - 15 of 15 Posts
Top